CVE-2026-27853 Affecting dnsdist package, versions <1.9.13-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.49% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-DNSDIST-17781584
  • published2 Jul 2026
  • disclosed22 Jun 2026

Introduced: 22 Jun 2026

CVE-2026-27853  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 dnsdist to version 1.9.13-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dnsdist package and not the dnsdist package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

An attacker might be able to trigger an out-of-bounds write by sending crafted DNS responses to a DNSdist using the DNSQuestion:changeName or DNSResponse:changeName methods in custom Lua code. In some cases the rewritten packet might become larger than the initial response and even exceed 65535 bytes, potentially leading to a crash resulting in denial of service.

CVSS Base Scores

version 3.1