CVE-2026-40211 Affecting dnsdist package, versions <1.9.15-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.7% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-DNSDIST-18791634
  • published14 Aug 2026
  • disclosed5 Aug 2026

Introduced: 5 Aug 2026

CVE-2026-40211  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 dnsdist to version 1.9.15-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dnsdist package and not the dnsdist package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

An attacker can send crafted DNS over HTTP/3 queries, triggering an exception that prevents some buffer from being freed right away. The buffer will be freed at the end of the QUIC connection, but on some setups it might be possible to open enough concurrent DoH3 streams to trigger an out-of-memory condition, resulting in a denial of service.

CVSS Base Scores

version 3.1