Improper Validation of Array Index Affecting fontforge-devel package, versions <20251009-160000.2.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.61% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-FONTFORGEDEVEL-16331460
  • published1 May 2026
  • disclosed22 Apr 2026

Introduced: 22 Apr 2026

CVE-2025-15270  (opens in a new tab)
CWE-129  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 fontforge-devel to version 20251009-160000.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fontforge-devel package and not the fontforge-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

FontForge SFD File Parsing Improper Validation of Array Index Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of FontForge. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of SFD files. The issue results from the lack of proper validation of user-supplied data, which can result in a write past the end of an allocated array. An attacker can leverage this vulnerability to execute code in the context of the current user. Was ZDI-CAN-28563.

CVSS Base Scores

version 3.1