Out-of-bounds Write Affecting gdk-pixbuf-loader-libheif package, versions <1.23.5-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
5.29% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-GDKPIXBUFLOADERLIBHEIF-21359152
  • published21 Oct 2026
  • disclosed8 Oct 2026

Introduced: 8 Oct 2026

NewCVE-2020-6851  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 gdk-pixbuf-loader-libheif to version 1.23.5-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gdk-pixbuf-loader-libheif package and not the gdk-pixbuf-loader-libheif package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

OpenJPEG through 2.3.1 has a heap-based buffer overflow in opj_t1_clbl_decode_processor in openjp2/t1.c because of lack of opj_j2k_update_image_dimensions validation.

CVSS Base Scores

version 3.1