Stack-based Buffer Overflow Affecting ghostscript package, versions <10.06.0-160000.1.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.2% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-GHOSTSCRIPT-16331673
  • published1 May 2026
  • disclosed21 Apr 2026

Introduced: 21 Apr 2026

CVE-2025-59801  (opens in a new tab)
CWE-121  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 ghostscript to version 10.06.0-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghostscript package and not the ghostscript package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

In Artifex GhostXPS before 10.06.0, there is a stack-based buffer overflow in xps_unpredict_tiff in xpstiff.c because the samplesperpixel value is not checked.