CVE-2025-46646 Affecting ghostscript-devel package, versions <10.06.0-160000.1.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-GHOSTSCRIPTDEVEL-16331661
  • published1 May 2026
  • disclosed21 Apr 2026

Introduced: 21 Apr 2026

CVE-2025-46646  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 ghostscript-devel to version 10.06.0-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghostscript-devel package and not the ghostscript-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

In Artifex Ghostscript before 10.05.0, decode_utf8 in base/gp_utf8.c mishandles overlong UTF-8 encoding. NOTE: this issue exists because of an incomplete fix for CVE-2024-46954.

CVSS Base Scores

version 3.1