Heap-based Buffer Overflow Affecting ghostscript-devel package, versions <10.08.0-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.85% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-GHOSTSCRIPTDEVEL-21358588
  • published21 Oct 2026
  • disclosed9 Oct 2026

Introduced: 9 Oct 2026

NewCVE-2026-39919  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 ghostscript-devel to version 10.08.0-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghostscript-devel package and not the ghostscript-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Ghostscript before 10.08.0 contains a heap-based buffer overflow vulnerability in the JPEG 2000 output adapter (base/sjpx_openjpeg.c) that allows attackers to cause memory corruption by supplying a crafted PDF containing a JPEG 2000 image with mismatched component subsampling factors. When image components declare different subsampling values, the non-samescale sub-byte-depth output path allocates a row buffer sized for packed output but writes a full byte per output column regardless of bit depth, overflowing the allocation and corrupting internal chunk-allocator metadata to achieve code execution.

CVSS Base Scores

version 3.1