Integer Overflow or Wraparound Affecting ghostscript-x11 package, versions <10.06.0-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-GHOSTSCRIPTX11-16331694
  • published1 May 2026
  • disclosed21 Apr 2026

Introduced: 21 Apr 2026

CVE-2025-59800  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 ghostscript-x11 to version 10.06.0-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghostscript-x11 package and not the ghostscript-x11 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

In Artifex Ghostscript through 10.05.1, ocr_begin_page in devices/gdevpdfocr.c has an integer overflow that leads to a heap-based buffer overflow in ocr_line8.

CVSS Base Scores

version 3.1