Memory Leak Affecting gprofng package, versions <2.45-160000.1.1


Severity

Recommended
low

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.61% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-GPROFNG-14425849
  • published16 Dec 2025
  • disclosed12 Dec 2025

Introduced: 12 Dec 2025

CVE-2025-1152  (opens in a new tab)
CWE-401  (opens in a new tab)
CWE-404  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 gprofng to version 2.45-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gprofng package and not the gprofng package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A vulnerability classified as problematic has been found in GNU Binutils 2.43. Affected is the function xstrdup of the file xstrdup.c of the component ld. The manipulation leads to memory leak. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. It is recommended to apply a patch to fix this issue. The code maintainer explains: "I'm not going to commit some of the leak fixes I've been working on to the 2.44 branch due to concern that would destabilise ld. All of the reported leaks in this bugzilla have been fixed on binutils master."

CVSS Base Scores

version 3.1