CVE-2025-11230 Affecting haproxy package, versions <3.2.0+git0.e134140d2-160000.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.74% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-HAPROXY-15053984
  • published22 Jan 2026
  • disclosed14 Jan 2026

Introduced: 14 Jan 2026

CVE-2025-11230  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 haproxy to version 3.2.0+git0.e134140d2-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haproxy package and not the haproxy package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Inefficient algorithm complexity in mjson in HAProxy allows remote attackers to cause a denial of service via specially crafted JSON requests.

CVSS Base Scores

version 3.1