Improper Handling of Length Parameter Inconsistency Affecting haproxy package, versions <3.2.12+git0.6011f448e-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.48% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-HAPROXY-15428491
  • published6 Mar 2026
  • disclosed27 Feb 2026

Introduced: 27 Feb 2026

CVE-2026-26081  (opens in a new tab)
CWE-130  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 haproxy to version 3.2.12+git0.6011f448e-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haproxy package and not the haproxy package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

HAProxy Community Edition 3.0 through 3.3 before 3.3.3 lacks a length check for the NEW_TOKEN format. HAProxy Enterprise and ALOHA are also affected.

CVSS Base Scores

version 3.1