Unchecked Return Value Affecting haproxy package, versions <3.2.12+git0.6011f448e-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.55% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-HAPROXY-15428508
  • published6 Mar 2026
  • disclosed27 Feb 2026

Introduced: 27 Feb 2026

CVE-2026-26080  (opens in a new tab)
CWE-252  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 haproxy to version 3.2.12+git0.6011f448e-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream haproxy package and not the haproxy package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also affected.

CVSS Base Scores

version 3.1