Incomplete Blacklist Affecting hawk2 package, versions <2.7.2+git.1788518533.7d4dadd6-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.39% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-HAWK2-21363696
  • published21 Oct 2026
  • disclosed9 Oct 2026

Introduced: 9 Oct 2026

NewCVE-2026-73491  (opens in a new tab)
CWE-184  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 hawk2 to version 2.7.2+git.1788518533.7d4dadd6-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hawk2 package and not the hawk2 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. From 2.25.0 until 2.25.2, Loofah::HTML5::Scrub.allowed_uri? does not reject javascript: URIs whose scheme is split or prefixed with the HTML5 named whitespace character references &Tab; or &NewLine;. CGI.unescapeHTML leaves those references intact, so allowed_uri? reports the URL safe even though a browser decodes and strips the tab or line feed and executes the resulting javascript: URL. This issue affects only callers that pass HTML-encoded strings directly to allowed_uri?; Loofah's default sanitize() path is not affected. This issue is fixed in version 2.25.2.

CVSS Base Scores

version 3.1