Cross-site Scripting (XSS) Affecting hawk2 package, versions <2.7.2+git.1788518533.7d4dadd6-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.3% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-HAWK2-21364285
  • published21 Oct 2026
  • disclosed9 Oct 2026

Introduced: 9 Oct 2026

NewCVE-2026-73490  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 hawk2 to version 2.7.2+git.1788518533.7d4dadd6-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hawk2 package and not the hawk2 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Prior to 2.25.2, Loofah's HTML5 sanitizer applies its local-reference restriction only to the xlink:href attribute on SVG use and feImage elements, while browsers also accept the plain href attribute. A crafted sanitized SVG can therefore reference an arbitrary same-origin external document; use may render external SVG content containing scripts or other dangerous content, and feImage may load external images for tracking. Applications that sanitize user-supplied SVG with Loofah's default allowlist are affected. This issue is fixed in version 2.25.2.

CVSS Base Scores

version 3.1