CVE-2026-1709 Affecting keylime-config package, versions <7.14.0+0-160000.1.1


Severity

Recommended
0.0
critical
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
5.79% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-KEYLIMECONFIG-15912556
  • published6 Apr 2026
  • disclosed19 Mar 2026

Introduced: 19 Mar 2026

CVE-2026-1709  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 keylime-config to version 7.14.0+0-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream keylime-config package and not the keylime-config package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in Keylime. The Keylime registrar, since version 7.12.0, does not enforce client-side Transport Layer Security (TLS) authentication. This authentication bypass vulnerability allows unauthenticated clients with network access to perform administrative operations, including listing agents, retrieving public Trusted Platform Module (TPM) data, and deleting agents, by connecting without presenting a client certificate.

CVSS Base Scores

version 3.1