Improper Authentication Affecting kubevirt-virtctl package, versions <1.7.0-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.2% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-KUBEVIRTVIRTCTL-15428693
  • published6 Mar 2026
  • disclosed27 Feb 2026

Introduced: 27 Feb 2026

CVE-2025-64434  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 kubevirt-virtctl to version 1.7.0-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kubevirt-virtctl package and not the kubevirt-virtctl package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

KubeVirt is a virtual machine management add-on for Kubernetes. Prior to 1.5.3 and 1.6.1, due to the peer verification logic in virt-handler (via verifyPeerCert), an attacker who compromises a virt-handler instance, could exploit these shared credentials to impersonate virt-api and execute privileged operations against other virt-handler instances potentially compromising the integrity and availability of the VM managed by it. This vulnerability is fixed in 1.5.3 and 1.6.1.

CVSS Base Scores

version 3.1