Use of Insufficiently Random Values Affecting libavahi-glib-devel package, versions <0.8-160000.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.62% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBAVAHIGLIBDEVEL-15014065
  • published17 Jan 2026
  • disclosed11 Jan 2026

Introduced: 11 Jan 2026

CVE-2024-52615  (opens in a new tab)
CWE-330  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libavahi-glib-devel to version 0.8-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libavahi-glib-devel package and not the libavahi-glib-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in Avahi-daemon, which relies on fixed source ports for wide-area DNS queries. This issue simplifies attacks where malicious DNS responses are injected.

CVSS Base Scores

version 3.1