Out-of-bounds Write Affecting libavutil59 package, versions <7.1.4-160000.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.49% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBAVUTIL59-19288918
  • published27 Aug 2026
  • disclosed12 Aug 2026

Introduced: 12 Aug 2026

CVE-2026-66041  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libavutil59 to version 7.1.4-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libavutil59 package and not the libavutil59 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

FFmpeg 7.0 through 8.1.2, fixed in commit 4da9812, contains a heap out-of-bounds write vulnerability in the vf_quirc filter that allows an attacker to corrupt heap memory by supplying a crafted PGS/SUP subtitle file with mismatched frame dimensions. Attackers can provide a subtitle file whose second presentation has larger dimensions than its first, causing av_image_copy_plane() to copy data exceeding the initial allocation size into the undersized libquirc grayscale image buffer, resulting in heap corruption and process crash with potential for code execution.

CVSS Base Scores

version 3.1