Out-of-bounds Write Affecting libgcrypt20 package, versions <1.12.1-160000.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBGCRYPT20-18345844
  • published28 Jul 2026
  • disclosed20 Jul 2026

Introduced: 20 Jul 2026

CVE-2026-41989  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libgcrypt20 to version 1.12.1-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.

CVSS Base Scores

version 3.1