Out-of-bounds Write Affecting libgcrypt-devel-x86-64-v3 package, versions <1.12.1-160000.2.1


Severity

Recommended
medium

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.23% (14th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBGCRYPTDEVELX8664V3-17781358
  • published2 Jul 2026
  • disclosed24 Jun 2026

Introduced: 24 Jun 2026

CVE-2026-41990  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libgcrypt-devel-x86-64-v3 to version 1.12.1-160000.2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt-devel-x86-64-v3 package and not the libgcrypt-devel-x86-64-v3 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.

CVSS Base Scores

version 3.1