Reachable Assertion Affecting liblasso-devel package, versions <2.8.2-160000.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.61% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBLASSODEVEL-14376265
  • published11 Dec 2025
  • disclosed25 Nov 2025

Introduced: 25 Nov 2025

CVE-2025-46705  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 liblasso-devel to version 2.8.2-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblasso-devel package and not the liblasso-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A denial of service vulnerability exists in the g_assert_not_reached functionality of Entr&#39;ouvert Lasso 2.5.1 and 2.8.2. A specially crafted SAML assertion response can lead to a denial of service. An attacker can send a malformed SAML response to trigger this vulnerability.

CVSS Base Scores

version 3.1