Integer Overflow or Wraparound Affecting liblcms2-doc package, versions <2.16-160000.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.13% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBLCMS2DOC-17875286
  • published7 Jul 2026
  • disclosed1 Jul 2026

Introduced: 1 Jul 2026

CVE-2026-42798  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 liblcms2-doc to version 2.16-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblcms2-doc package and not the liblcms2-doc package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Little CMS (lcms2) 2.16 through 2.18 before 2.19 has an integer overflow in ParseCube in cmscgats.c.

CVSS Base Scores

version 3.1