Incorrect Privilege Assignment Affecting libpackagekit-glib2-18 package, versions <1.2.8-160000.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBPACKAGEKITGLIB218-18344724
  • published28 Jul 2026
  • disclosed22 Jul 2026

Introduced: 22 Jul 2026

CVE-2026-10294  (opens in a new tab)
CWE-266  (opens in a new tab)
CWE-285  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libpackagekit-glib2-18 to version 1.2.8-160000.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpackagekit-glib2-18 package and not the libpackagekit-glib2-18 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A vulnerability has been found in PackageKit up to 1.3.5. Affected is the function g_file_test of the file src/pk-transaction.c of the component API. Such manipulation of the argument frontend-socket leads to improper authorization. The attack can be executed remotely. The exploit has been disclosed to the public and may be used.

CVSS Base Scores

version 3.1