CVE-2026-31912 Affecting libpcap1 package, versions <1.10.5-160000.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.11% (1st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBPCAP1-20306261
  • published30 Sept 2026
  • disclosed23 Sept 2026

Introduced: 23 Sep 2026

CVE-2026-31912  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libpcap1 to version 1.10.5-160000.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap1 package and not the libpcap1 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

libpcap BPF interpreter detects neither reaching the end of the filter program buffer due to lack of a return instruction nor executing a jump instruction with an offset that translates to a pointer outside of the buffer. In particular uncommon use cases a crafted filter program can cause the interpreter to try reading the OS process memory in the 32GiB around the buffer on 64-bit architectures and in the entire address space on 32-bit architectures.

CVSS Base Scores

version 3.1