CVE-2026-6554 Affecting libpcap1 package, versions <1.10.5-160000.5.1


Severity

Recommended
0.0
low
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBPCAP1-20306279
  • published30 Sept 2026
  • disclosed23 Sept 2026

Introduced: 23 Sep 2026

CVE-2026-6554  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libpcap1 to version 1.10.5-160000.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap1 package and not the libpcap1 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

libpcap BPF interpreter treats the offset in the 'ja L' BPF instruction as a signed integer to implement looping via backward jumps, but it does not limit the number of loop iterations. A crafted filter program or the 'protochain' primitive used on a crafted network packet can cause the interpreter to loop infinitely.

CVSS Base Scores

version 3.1