CVE-2026-0799 Affecting libpcap-devel package, versions <1.10.5-160000.5.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBPCAPDEVEL-20306283
  • published30 Sept 2026
  • disclosed23 Sept 2026

Introduced: 23 Sep 2026

CVE-2026-0799  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libpcap-devel to version 1.10.5-160000.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap-devel package and not the libpcap-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

In BPF instructions that load/store a value from/to a scratch memory register the register index is an unsigned 32-bit integer and must not exceed 15, but libpcap BPF interpreter does not validate the value. In particular uncommon use cases a crafted filter program can cause the interpreter to try reading and writing the OS process memory in the 16GiB starting at the current stack frame on 64-bit architectures and in the entire address space on 32-bit architectures.

CVSS Base Scores

version 3.1