Out-of-bounds Write Affecting libpcre2-16-0 package, versions <10.45-160000.3.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.86% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBPCRE2160-16120930
  • published22 Apr 2026
  • disclosed10 Apr 2026

Introduced: 10 Apr 2026

CVE-2025-58050  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libpcre2-16-0 to version 10.45-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcre2-16-0 package and not the libpcre2-16-0 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

The PCRE2 library is a set of C functions that implement regular expression pattern matching. In version 10.45, a heap-buffer-overflow read vulnerability exists in the PCRE2 regular expression matching engine, specifically within the handling of the (*scs:...) (Scan SubString) verb when combined with (*ACCEPT) in src/pcre2_match.c. This vulnerability may potentially lead to information disclosure if the out-of-bounds data read during the memcmp affects the final match result in a way observable by the attacker. This issue has been resolved in version 10.46.

CVSS Base Scores

version 3.1