Improper Protection of Alternate Path Affecting libpcre2-8-0 package, versions <10.45-160000.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.43% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBPCRE280-20306292
  • published30 Sept 2026
  • disclosed23 Sept 2026

Introduced: 23 Sep 2026

CVE-2026-86145  (opens in a new tab)
CWE-424  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libpcre2-8-0 to version 10.45-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcre2-8-0 package and not the libpcre2-8-0 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

PCRE2 before 10.48 allows a pcre2_dfa_match out-of-bounds write because reuse of a cached workspace block, in a recursive DFA matching workspace, lacks a size check (even though a newly allocated block, for the same purpose, does have a size check). This outcome requires an attacker-controlled regular expression, or a recursive pattern in conjunction with a small heap limit (this can be set through the API).

CVSS Base Scores

version 3.1