Out-of-bounds Read Affecting libpcre2-posix3 package, versions <10.45-160000.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.29% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBPCRE2POSIX3-20306332
  • published30 Sept 2026
  • disclosed23 Sept 2026

Introduced: 23 Sep 2026

CVE-2026-89156  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libpcre2-posix3 to version 10.45-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcre2-posix3 package and not the libpcre2-posix3 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

PCRE2 before 10.48 has a pcre2_match out-of-bounds read after a JIT fallback when an attacker can provide invalid UTF data.

CVSS Base Scores

version 3.1