Use After Free Affecting librsvg-devel package, versions <2.60.3-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

Social Trends
Exploit Maturity
Proof of Concept
EPSS
0.54% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBRSVGDEVEL-21353582
  • published21 Oct 2026
  • disclosed8 Oct 2026

Introduced: 8 Oct 2026

NewCVE-2026-96889  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 librsvg-devel to version 2.60.3-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream librsvg-devel package and not the librsvg-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in librsvg. When processing an SVG document containing nested XML inclusions (Xincludes) with duplicate entity declarations, a use-after-free error can occur. This vulnerability arises because the library incorrectly frees an XML entity that is still in use by the parser. An attacker could potentially exploit this to cause a denial of service or execute arbitrary code.

CVSS Base Scores

version 3.1