CVE-2025-56226 Affecting libsndfile1 package, versions <1.2.2-160000.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.37% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBSNDFILE1-16961984
  • published28 May 2026
  • disclosed22 May 2026

Introduced: 22 May 2026

CVE-2025-56226  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libsndfile1 to version 1.2.2-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsndfile1 package and not the libsndfile1 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Libsndfile <=1.2.2 contains a memory leak vulnerability in the mpeg_l3_encoder_init() function within the mpeg_l3_encode.c file.

CVSS Base Scores

version 3.1