Incomplete Blacklist Affecting libsodium-devel package, versions <1.0.21-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBSODIUMDEVEL-16420015
  • published5 May 2026
  • disclosed28 Apr 2026

Introduced: 28 Apr 2026

CVE-2025-69277  (opens in a new tab)
CWE-184  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libsodium-devel to version 1.0.21-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsodium-devel package and not the libsodium-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

libsodium before ad3004e, in atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group.

CVSS Base Scores

version 3.1