Out-of-bounds Read Affecting libsss_nss_idmap-devel package, versions <2.10.2-160000.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.13% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBSSSNSSIDMAPDEVEL-20261743
  • published29 Sept 2026
  • disclosed3 Sept 2026

Introduced: 3 Sep 2026

CVE-2026-68743  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libsss_nss_idmap-devel to version 2.10.2-160000.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsss_nss_idmap-devel package and not the libsss_nss_idmap-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in SSSD. The extract_authtok_v1() function in the PAM responder does not validate the auth_token_length field against the remaining buffer size before processing. A local attacker can exploit this via a crafted protocol v1 request to the PAM responder socket, causing an out-of-bounds read and process crash, resulting in a denial of service.

CVSS Base Scores

version 3.1