Heap-based Buffer Overflow Affecting libXfont2-2 package, versions <2.0.7-160000.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.43% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBXFONT22-18000759
  • published17 Jul 2026
  • disclosed10 Jul 2026

Introduced: 10 Jul 2026

CVE-2026-56002  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libXfont2-2 to version 2.0.7-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libXfont2-2 package and not the libXfont2-2 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A heap bufferflow in pcfReadFont() due to missing glyph bounds checking in libXfont2 before 2.0.8  allows attackers authenticated as X client to execute code within the X server.

CVSS Base Scores

version 3.1