Access of Resource Using Incompatible Type ('Type Confusion') Affecting libxml2-devel package, versions <2.13.8-160000.5.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.63% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBXML2DEVEL-18000303
  • published17 Jul 2026
  • disclosed13 Jul 2026

Introduced: 13 Jul 2026

CVE-2026-6732  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libxml2-devel to version 2.13.8-160000.5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml2-devel package and not the libxml2-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in libxml2. This vulnerability occurs when the library processes a specially crafted XML Schema Definition (XSD) validated document that includes an internal entity reference. An attacker could exploit this by providing a malicious document, leading to a type confusion error that causes the application to crash. This results in a denial of service (DoS), making the affected system or application unavailable.

CVSS Base Scores

version 3.1