Expired Pointer Dereference Affecting libxml2-tools package, versions <2.13.8-160000.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.17% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBXML2TOOLS-15439823
  • published7 Mar 2026
  • disclosed4 Mar 2026

Introduced: 4 Mar 2026

CVE-2025-10911  (opens in a new tab)
CWE-825  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libxml2-tools to version 2.13.8-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxml2-tools package and not the libxml2-tools package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A use-after-free vulnerability was found in libxslt while parsing xsl nodes that may lead to the dereference of expired pointers and application crash.

CVSS Base Scores

version 3.1