Directory Traversal Affecting libzypp package, versions <17.38.13-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.42% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-LIBZYPP-17439615
  • published24 Jun 2026
  • disclosed19 Jun 2026

Introduced: 19 Jun 2026

CVE-2026-44942  (opens in a new tab)
CWE-24  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 libzypp to version 17.38.13-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libzypp package and not the libzypp package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A path traversal in handling the "path" component of .repo files processed by libzypp before 17.38.13 in the 17.x series, or before 16.22.19 could be used by attackers to fill directories on the system outside of the zypp cache with content.

CVSS Base Scores

version 3.1