Incorrect Authorization Affecting mariadb-client package, versions <11.8.8-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-MARIADBCLIENT-17342904
  • published16 Jun 2026
  • disclosed10 Jun 2026

Introduced: 10 Jun 2026

CVE-2026-44169  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 mariadb-client to version 11.8.8-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mariadb-client package and not the mariadb-client package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

MariaDB server is a community developed fork of MySQL server. From versions 11.4.1 to before 11.4.11, 11.8.1 to before 11.8.7, and 12.3.1, a user getting EXECUTE access to a stored routine via a role, could see the routine definition even without SHOW CREATE ROUTINE privilege. This issue has been patched in versions 11.4.11, 11.8.7, and 12.3.2.

CVSS Base Scores

version 3.1