Improper Handling of Unicode Encoding Affecting MozillaFirefox-devel package, versions <153.5.0-160000.1.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.4% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-MOZILLAFIREFOXDEVEL-21477594
  • published23 Oct 2026
  • disclosed19 Oct 2026

Introduced: 19 Oct 2026

NewCVE-2026-93990  (opens in a new tab)
CWE-176  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 MozillaFirefox-devel to version 153.5.0-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream MozillaFirefox-devel package and not the MozillaFirefox-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Expat before 2.8.5 fails to validate that a high surrogate in UTF-16 input is followed by a low surrogate, allowing malformed UTF-16 sequences to be accepted. Attackers can supply UTF-16 encoded XML containing lone high surrogates that consume the following code unit, causing Expat to pass unpaired surrogates to applications built with XML_UNICODE and to silently replace input characters in other builds.

CVSS Base Scores

version 3.1