CVE-2025-30706 Affecting mysql-connector-java package, versions <9.3.0-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.63% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-MYSQLCONNECTORJAVA-14376147
  • published11 Dec 2025
  • disclosed26 Nov 2025

Introduced: 26 Nov 2025

CVE-2025-30706  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 mysql-connector-java to version 9.3.0-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mysql-connector-java package and not the mysql-connector-java package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J). Supported versions that are affected are 9.0.0-9.2.0. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.1 Base Score 7.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H).

CVSS Base Scores

version 3.1