File Descriptor Leak Affecting pcp-pmda-mic package, versions <6.2.0-160000.4.1


Severity

Recommended
critical

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.57% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PCPPMDAMIC-19682158
  • published11 Sept 2026
  • disclosed24 Aug 2026

Introduced: 24 Aug 2026

CVE-2026-16526  (opens in a new tab)
CWE-403  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 pcp-pmda-mic to version 6.2.0-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcp-pmda-mic package and not the pcp-pmda-mic package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw in the PCP linux_sockets module exposes an unsecured internal connection. An attacker with initial code execution can exploit this to escalate privileges and execute arbitrary commands as root.

CVSS Base Scores

version 3.1