Directory Traversal Affecting pcp-pmda-sendmail package, versions <6.2.0-160000.4.1


Severity

Recommended
critical

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.51% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PCPPMDASENDMAIL-19682483
  • published11 Sept 2026
  • disclosed24 Aug 2026

Introduced: 24 Aug 2026

CVE-2026-16531  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 pcp-pmda-sendmail to version 6.2.0-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcp-pmda-sendmail package and not the pcp-pmda-sendmail package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

An unauthenticated remote attacker can exploit a path traversal vulnerability in the PCP pmproxy logger servlet using a crafted hostname. This allows arbitrary file and directory creation, potentially leading to a denial of service.

CVSS Base Scores

version 3.1