Out-of-bounds Read Affecting pcp-pmda-zswap package, versions <6.2.0-160000.4.1


Severity

Recommended
critical

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.49% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PCPPMDAZSWAP-19682298
  • published11 Sept 2026
  • disclosed24 Aug 2026

Introduced: 24 Aug 2026

CVE-2026-16530  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 pcp-pmda-zswap to version 6.2.0-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcp-pmda-zswap package and not the pcp-pmda-zswap package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in the PCP (Performance Co-Pilot) pmproxy service. A remote attacker can exploit a vulnerability in the pmLogLoadInDom() function by sending a specially crafted request. This bypasses a critical bounds check, which can lead to the pmproxy service crashing, causing a Denial of Service (DoS). Additionally, this flaw may enable the leakage of sensitive information from the system's memory.

CVSS Base Scores

version 3.1