Incorrect Resource Transfer Between Spheres Affecting pcre2-doc package, versions <10.45-160000.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.16% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PCRE2DOC-20306296
  • published30 Sept 2026
  • disclosed23 Sept 2026

Introduced: 23 Sep 2026

CVE-2026-89162  (opens in a new tab)
CWE-669  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 pcre2-doc to version 10.45-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre2-doc package and not the pcre2-doc package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

In PCRE2 before 10.48, pcre2_serialize_encode might disclose two bytes to an adversary, typically in a situation where the access available to the adversary is already unsafe.

CVSS Base Scores

version 3.1