CVE-2026-3172 Affecting pgvector-devel package, versions <0.8.2-160000.1.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PGVECTORDEVEL-16121205
  • published22 Apr 2026
  • disclosed9 Apr 2026

Introduced: 9 Apr 2026

CVE-2026-3172  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 pgvector-devel to version 0.8.2-160000.1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pgvector-devel package and not the pgvector-devel package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Buffer overflow in parallel HNSW index build in pgvector 0.6.0 through 0.8.1 allows a database user to leak sensitive data from other relations or crash the database server.

CVSS Base Scores

version 3.1