Information Exposure Affecting php-composer2 package, versions <2.8.9-160000.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.02% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PHPCOMPOSER2-18821450
  • published15 Aug 2026
  • disclosed3 Aug 2026

Introduced: 3 Aug 2026

CVE-2026-45793  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 php-composer2 to version 2.8.9-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-composer2 package and not the php-composer2 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Composer is a dependency Manager for the PHP language. Prior to 1.10.28, 2.2.28, and 2.9.8, Composer\IO\BaseIO::loadConfiguration() validates GitHub OAuth tokens with the regex ^[.A-Za-z0-9_]+$ and interpolates rejected tokens into an UnexpectedValueException; GitHub Actions GITHUB_TOKEN values using the ghs_<id>_<base64url-JWT> format can contain -, fail validation, and be disclosed to stderr or CI logs. This issue is fixed in versions 1.10.28, 2.2.28, and 2.9.8.

CVSS Base Scores

version 3.1