Directory Traversal Affecting php-composer2 package, versions <2.8.9-160000.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.14% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PHPCOMPOSER2-18823139
  • published15 Aug 2026
  • disclosed3 Aug 2026

Introduced: 3 Aug 2026

CVE-2026-59948  (opens in a new tab)
CWE-22  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 php-composer2 to version 2.8.9-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-composer2 package and not the php-composer2 package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.

CVSS Base Scores

version 3.1