Improper Certificate Validation Affecting podman-remote package, versions <5.4.2-160000.4.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.52% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PODMANREMOTE-15439962
  • published7 Mar 2026
  • disclosed3 Mar 2026

Introduced: 3 Mar 2026

CVE-2025-6032  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 podman-remote to version 5.4.2-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream podman-remote package and not the podman-remote package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

A flaw was found in Podman. The podman machine init command fails to verify the TLS certificate when downloading the VM images from an OCI registry. This issue results in a Man In The Middle attack.

CVSS Base Scores

version 3.1