Directory Traversal Affecting podmansh package, versions <5.4.2-160000.3.1


Severity

Recommended
0.0
high
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
1.16% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PODMANSH-15075755
  • published24 Jan 2026
  • disclosed21 Jan 2026

Introduced: 21 Jan 2026

CVE-2025-9566  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 podmansh to version 5.4.2-160000.3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream podmansh package and not the podmansh package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

There's a vulnerability in podman where an attacker may use the kube play command to overwrite host files when the kube file container a Secrete or a ConfigMap volume mount and such volume contains a symbolic link to a host file path. In a successful attack, the attacker can only control the target file to be overwritten but not the content to be written into the file.

Binary-Affected: podman Upstream-version-introduced: v4.0.0 Upstream-version-fixed: v5.6.1

References

CVSS Base Scores

version 3.1