Reachable Assertion Affecting python313-avahi package, versions <0.8-160000.4.1


Severity

Recommended
0.0
medium
0
10

Based on SUSE Linux Enterprise Server security rating.

Threat Intelligence

EPSS
0.16% (5th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-SLES1600-PYTHON313AVAHI-15135082
  • published29 Jan 2026
  • disclosed26 Jan 2026

Introduced: 26 Jan 2026

CVE-2025-68276  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade SLES:16.0.0 python313-avahi to version 0.8-160000.4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python313-avahi package and not the python313-avahi package as distributed by SLES. See How to fix? for SLES:16.0.0 relevant fixed versions and status.

Avahi is a system which facilitates service discovery on a local network via the mDNS/DNS-SD protocol suite. In 0.9-rc2 and earlier, an unprivileged local users can crash avahi-daemon (with wide-area disabled) by creating record browsers with the AVAHI_LOOKUP_USE_WIDE_AREA flag set via D-Bus. This can be done by either calling the RecordBrowserNew method directly or creating hostname/address/service resolvers/browsers that create those browsers internally themselves.

CVSS Base Scores

version 3.1